1999 Yamaha Golf Cart- gas

Reply

  #1  
Old 04-22-15, 12:05 PM
Member
Thread Starter
Join Date: Apr 2015
Location: USA
Posts: 1
1999 Yamaha Golf Cart- gas

I've got a 1999 Yamaha gas-powered golf cart. I am unsure as to the specifics of the model/engine type; I got it second-hand.

I put the cart away for the winter. Prior to putting it away, it ran plenty fine. I ran stabil through, pulled the battery and stored in area where rodents, etc. couldn't get it. I'm now in the process of dewinterizing. I charged and replaced the battery. Checked the spark plug. Turned key on, pushed the pedal, and nothing. I can here just a slight click in the compartment, but nothing. I've attempted to choke it, check the gas, etc., but to no avail. I know the battery is good, as I have hooked it up to another machine to check. Not sure what to check to get this back up and running.

Thanks
 
Sponsored Links
  #2  
Old 04-22-15, 04:08 PM
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 17,756
Try tapping on the solenoid, maybe it's stuck because of it's lack of use. You can also bypass around it to see if it's the source of the problem. But, the battery and it's connections should remain suspect and would be where I look first.

How did you test the battery? You just said you hooked it to another machine. You can also take it to an auto parts store and have them check it under load.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes