Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Briggs and Stratton 3.5hp Lawn mower Starts first pull, stalls out after 10min


Deal1's Avatar
Member

Join Date: May 2015
Posts: 2
CANADA

05-11-15, 08:43 AM   #1  
Briggs and Stratton 3.5hp Lawn mower Starts first pull, stalls out after 10min

I've been living with this for a while and would really like to fix it. My mower starts first pull every tiime after priming twice via the thumb bulb. It then runs fine for 10 minutes and then stalls. When it stalls I notice that the thumb bulb is completely sucked free of air and deflated. After waiting 30 minutes the thumb bulb is back to it's original shape and the engine will start again. This time it won't run more than a couple minutes.

I have run carb cleaner via the gas and changed the oil and sparkplug but nothing else.

Where should I start?

 
Sponsored Links
BFHFixit's Avatar
Forum Topic Moderator

Join Date: Jun 2007
Posts: 1,764
KS

05-11-15, 12:00 PM   #2  
Try loosening the fuel cap or look for a pinched or collapsed fuel line.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,573
GA

05-11-15, 04:51 PM   #3  
Sounds like the carb needs cleaning and a new diaphragm.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Deal1's Avatar
Member

Join Date: May 2015
Posts: 2
CANADA

05-12-15, 01:08 AM   #4  
Thanks for the advice. I found an instructional youtube video on replacing the diaphragm and cleaning the carb. I'm going to see if I can find the parts locally and give it a go this weekend.

 
Search this Thread