weed trimmer

Reply

  #1  
Old 06-14-15, 07:25 AM
Member
Thread Starter
Join Date: May 2014
Location: usa
Posts: 9
weed trimmer

Hi guys My current problem is with a Craftsman trimmer. It starts & will idle, but has little power. model #316.711370 I would Appreciate your thoughts about the possibilities. Thanks
 

Last edited by stucky; 06-14-15 at 07:27 AM. Reason: sorry about the butt
Sponsored Links
  #2  
Old 06-14-15, 07:29 AM
Member
Join Date: Jan 2011
Location: USA
Posts: 4,183
Look in the fuel tank and see if there's a filter inside the tank.
Broken or leaking fuel line.
Leaking primmer bulb.
Carb. needs rebuilding or replacing.
 
  #3  
Old 06-14-15, 11:17 AM
Member
Join Date: Feb 2006
Location: USA
Posts: 6,389
Symptoms

What you describe is the symptom of a clogged muffler.
 
  #4  
Old 06-14-15, 11:23 AM
chandler's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Dec 2005
Location: USA
Posts: 39,968
Have you adjusted the two screws for mixture at high speed versus low speed? As Joe says, the filter may be clogged.
 
  #5  
Old 06-14-15, 05:30 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
I'mwith Wirepuller38. Check it without the muffler.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes