Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

Generac xg7000e won't produce power


Shelby04861's Avatar
Member

Join Date: Jun 2015
Posts: 2
ME

06-29-15, 03:13 AM   #1  
Generac xg7000e won't produce power

I have a Generac xg7000e(005798-0) that stopped producing power while running. It has 12.2 hours on the meter and runs great! Was running the whole house and then stopped producing power while continuing to run. Trying to figure out where to start with diagnosis and repair. Here is what I can tell you so far. Fires right up on first pull. Battery is dead so electric start is a no go for now. Hour meter displays just fine. When checking the circuit breakers on the panel, they are all jiggly like I think they are supposed to be until they are tripped. On the 110v receptacles, you can't perform the test/reset, as they won't stick/click into position. When running there is no power meter or lights at all on the panel or any other indication of power. Can someone please help guide me through the process of diagnosis/repair.

 
Sponsored Links
Justin Smith's Avatar
Member

Join Date: Dec 2010
Posts: 2,546
PA

06-29-15, 08:42 AM   #2  
First thing I'd check, is the breaker tripped?

 
Shelby04861's Avatar
Member

Join Date: Jun 2015
Posts: 2
ME

06-29-15, 01:28 PM   #3  
The breaker buttons do t feel tripped. From my understanding they push out and are stiff when tripped. I am going to try to test for voltage on the backside of the plug panel. See if there is voltage before the breakers that is.


Last edited by Shelby04861; 06-29-15 at 01:30 PM. Reason: Additional info
 
Search this Thread