Broadmoor hydro 14 hp gave up mid-cut in the yard


  #1  
Old 07-20-15, 05:56 PM
H
Member
Thread Starter
Join Date: Jan 2009
Posts: 30
Received 0 Votes on 0 Posts
Broadmoor hydro 14 hp gave up mid-cut in the yard

After a struggle to start - 2-3x longer than normal on the ignition key - indoor stored, elderly but has worked great for the past 4 years since I bought it , oil ok, battery on full charge - I ran for 40 minutes and managed most of the yard - then.... power gradually dropped then stalled and I was done.

A turn of the key 2 mins later gave 10 seconds of engine running, and 6' of movement but then nothing.

There is fuel at the filter, the starter turns the engine, but no firing up.

Anything I missed before I pull the spark plug ?

Thanks in advance
Malcolm
 
  #2  
Old 07-20-15, 06:26 PM
J
Member
Join Date: Jan 2011
Location: USA
Posts: 5,007
Received 125 Votes on 110 Posts
At least 90% of the time it's a fuel issue.
Time to rebuild the carb.
 
  #3  
Old 07-21-15, 10:15 AM
P
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 28,144
Received 1,569 Votes on 1,410 Posts
Hard starting, surging, needs choke to run or runs at one rpm but not others are all signs of a dirty carburetor that may have a jet or orifice plugged, or the float/needle valve not working properly. Another possibility is the valves may be out of adjustment especially if the engine has a lot of hours on it. That can cause hard starting and can cause the engine to sputter or die and may get worse when it gets good and hot.
 
  #4  
Old 07-22-15, 07:01 PM
H
Member
Thread Starter
Join Date: Jan 2009
Posts: 30
Received 0 Votes on 0 Posts
Thanks for that direction

I'll have a go in that area then
Cheers
Malcolm
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: