onan generator 4k


  #1  
Old 10-19-15, 10:52 AM
V
Member
Thread Starter
Join Date: Oct 2015
Location: USA
Posts: 4
Received 0 Votes on 0 Posts
onan generator 4k

I only get a clicking sound when I hit the starter switch, Iv applied extra battery power by jumper cables and it still clicks, I've replaced solenoid and same results, the starter is new and tested out fine, its got a new brain in the process and still clicks when I try to start it, the motor turns normally, what have I missed /
 
  #2  
Old 10-19-15, 11:00 AM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 62,087
Received 1,509 Votes on 1,396 Posts
Welcome to the forums.

The 12+ goes from the battery thru the solenoid to the starter. Using a 12v test light or a meter you need to see where it's getting lost.

If you want an exact wiring path then you'll need to post the exact model number.
 
  #3  
Old 10-19-15, 11:13 AM
G
Member
Join Date: Oct 2002
Location: Hamilton County, Ohio
Posts: 4,295
Received 2 Votes on 2 Posts
If you bridge the battery cable and the cable to the starter, the starter should crank. The solenoid sounds like it is working correctly, but a meter will tell if it is actually passing voltage from the battery to the starter terminal.
 
  #4  
Old 10-19-15, 12:07 PM
V
Member
Thread Starter
Join Date: Oct 2015
Location: USA
Posts: 4
Received 0 Votes on 0 Posts
12 volt

I replaced the solenoid and had the same result even when I put another battery to it with jumpers. I read 12 volts +
 
  #5  
Old 10-19-15, 08:22 PM
V
Member
Thread Starter
Join Date: Oct 2015
Location: USA
Posts: 4
Received 0 Votes on 0 Posts
Solenoid

Thanks for all the input, I found the problem, the power side was off a relay that limited amps, the mechanic hooked it up at the wrong source.

Thanks !
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: