Scotts L2048 Lawn Tractor Ignition and PTO problems.


  #1  
Old 11-02-15, 12:11 PM
J
Member
Thread Starter
Join Date: Nov 2006
Location: South Jersey
Posts: 317
Received 0 Upvotes on 0 Posts
Scotts L2048 Lawn Tractor Ignition and PTO problems.

Couple of problems that seem to be related. 1) Engine still runs when operator is not present and brake released.. When key is shut off engine runs for 3-5 seconds then shuts off. Seems like shut off is due to fuel solenoid shut off rather than ignition ground. 2) PTO will not engage with seat switch depressed. Let go of seat switch button and PTO engages for a couple seconds then stops and also shuts down engine. I have replaced seat switch. PTO switch tests fine per manual. This is a stock configuration. Please help.
 
  #2  
Old 11-02-15, 03:37 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 15,988
Received 146 Upvotes on 135 Posts
It sounds like a bad relay problem.
 
  #3  
Old 11-03-15, 12:07 PM
J
Member
Thread Starter
Join Date: Nov 2006
Location: South Jersey
Posts: 317
Received 0 Upvotes on 0 Posts
I went through the procedure for checking all the components in the electrical system. They all checked out ok.. However I think the problem is with the reverse switch on the transmission. I came to this conclusion from banging on the forward and reverse pedals with my foot and the mower engaged an the engine did not stall. I made two passes and it seemed fine. I came back to the garage to do some other adjustments and then tried it again and it did not work. Rats !!
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: