2005 Kohler pro 25 hp generator problems

Reply

  #1  
Old 03-25-16, 10:26 AM
Member
Thread Starter
Join Date: Mar 2016
Posts: 1
2005 Kohler pro 25 hp generator problems

Removed the Nikki carb because it was leaking fuel. Put back together and ran what I thought was normal. The owner can to pick up and said the idle was to high and that the throttle wasn't working right although I never did anything with the throttle. So I started playing with the throttle cable to make the throttle lever work right and it al went south from there. In the process the governor cable fell off. Not sure what hole it was in to start with. Now it won't idle and seems to be loading up when it try's to idle. Help me please
 
Sponsored Links
  #2  
Old 03-25-16, 12:32 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 45,048
Welcome to the forums.

I moved you to your own thread so that there is only one running for you.

It sounds like the carb has a float in it that is stuck. I'd check that first.

The pros will be by to help you out.
 
  #3  
Old 03-25-16, 03:47 PM
BFHFixit's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jun 2007
Location: USA.
Posts: 1,836
This could be a soup sandwich, but with some numbers and possibly pics, might be able to get you some direction.
First, we need the engine number and spec. If it is a "Command" Pro the number might be like CH640 followed by a -and four digits.
The model # of the generator might also be helpful.

you say the governor "Cable came off? If it is a cable and not a linkage, then that should run to your throttle control and not too big of a deal.
 
  #4  
Old 03-27-16, 09:02 PM
Member
Join Date: Oct 2010
Location: USA
Posts: 210
Yes, please share model # of engine, should be on a sticker on the side. I have a Command Pro 25 & may be able to send you some pictures of how the linkage connects....

TexasFire
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes