Craftsman Kohler 26 HP engine starts but dies as soon as the start switch not on

Reply

  #1  
Old 07-03-16, 07:19 AM
Member
Thread Starter
Join Date: Jul 2016
Location: United States
Posts: 3
Craftsman Kohler 26 HP engine starts but dies as soon as the start switch not on

My Mower is starting but as soon as I let go of the start key it dies. If I hold the key on the engine stays running but we all know you cant do that. Any thoughts?
 
Sponsored Links
  #2  
Old 07-03-16, 08:44 AM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,728
What happened when it started doing it - "shut it off, running fine, started acting up" or "been sitting for a couple years" - that sort of thing.
 
  #3  
Old 07-03-16, 11:55 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
My fisrt suspect would be the ignition switch.
 
  #4  
Old 07-03-16, 03:05 PM
Member
Thread Starter
Join Date: Jul 2016
Location: United States
Posts: 3
mower

I sold it and the user had some issues with it. magnets came off flywheel wiped out stator so I replaced the flywheel and stater. I am thinking this is not all that happened as I see someone wired the fuel solenoid differently. I suspect they had some other problem that occured. Will call previous owner and ask some questions. Still have no power unless the ignition is in the start position.
 
  #5  
Old 07-03-16, 05:25 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,728
Do you have power to the fuel solenoid with the switch in the "run" position? That's about the only place you need power after it starts to run the engine. The kill/off position cuts the power to the fuel solenoid, but grounds the kill wire from the coil/module. Going from "start" to "run", takes power away from the starter solenoid and leaves it to the fuel solenoid.

It may be there was some rewiring that got everything crossed up.
 
  #6  
Old 07-04-16, 08:13 AM
Member
Thread Starter
Join Date: Jul 2016
Location: United States
Posts: 3
Thanks I will check to see what is going wrong with the wiring today and see if I can isolate the issue.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes