B&S, 12HP ..new carb and magneto .. runs over rich?!

Reply

  #1  
Old 08-18-16, 01:44 PM
Member
Thread Starter
Join Date: Sep 2011
Location: USA
Posts: 39
B&S, 12HP ..new carb and magneto .. runs over rich?!

Brand new parts - starts well ..runs pretty good. (starts to stagger at high RPM) ..but I can hardly run at all with an air cleaner in place?! Even without you can see it's over rich by the black exhaust. There's only one needle jet type thing ..moved it to One Turn out from closed.

Could there be dirt in the float bowl holding the pin open? Appreciate any help - thanks. Jim
 
Sponsored Links
  #2  
Old 08-18-16, 01:52 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,728
Is that an ebay carb for about 20 bucks?
 
  #3  
Old 08-22-16, 12:41 PM
Member
Thread Starter
Join Date: Sep 2011
Location: USA
Posts: 39
Sorry for the lag in my reply.. No it's the OEM (not close by - forgot name) bought from Amazon. My other B&S use the same mfgr.

Jim
 
  #4  
Old 08-22-16, 01:12 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,728
Did you try setting the mixture screw in clockwise or does that affect it at all.
 
  #5  
Old 08-22-16, 01:30 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,728
Start it and warm it up, then with the throttle set at full open shut off the fuel to the carburetor. Watch it closely to see if it starts to clean up before it dies from lack of fuel.
 
  #6  
Old 08-22-16, 03:17 PM
BFHFixit's Avatar
Banned. Rule And/Or Policy Violation
Join Date: Jun 2007
Location: USA.
Posts: 1,836
What are the engine numbers ?
 
  #7  
Old 08-22-16, 11:55 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,814
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes