Dewalt pressure washer idles too low when warm

Reply

  #1  
Old 11-10-16, 03:55 PM
Member
Thread Starter
Join Date: Jun 2007
Location: Ludlow, MA
Posts: 172
Dewalt pressure washer idles too low when warm

Anyone know what would cause this? The pressure washer works great when started, but after a minute or two, the engine drops in Idle and the pressure goes down. I havn't been able to find any throttle adjustment screws on the carb. Any one know what might be happening? Thank you!
 
Sponsored Links
  #2  
Old 11-10-16, 04:25 PM
Group Moderator
Join Date: Mar 2003
Location: NC, USA
Posts: 17,779
Post your model number so the experts can look it up.

Also, you mention that the idle speed drops but you also mention that the pressure goes down. People usually talk about the pressure when it's reved up. Is your high speed dropping or is it really the idle speed that's dropping?
 
  #3  
Old 11-10-16, 11:30 PM
Member
Thread Starter
Join Date: Jun 2007
Location: Ludlow, MA
Posts: 172
Now that you mention that, it seems to idle down and then not idle up when I pull the trigger. Any instant go to when that happens? Ill get the model number tomorrow.
 
  #4  
Old 11-10-16, 11:58 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,820
That's a problem with the unloader valve.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes