Craftsman Riding Mover Rear Neutral Lever Stuck - Will Not Push Back In

Reply

  #1  
Old 05-07-17, 01:07 PM
Member
Thread Starter
Join Date: Jan 2004
Location: Harrisburg, PA
Posts: 481
Craftsman Riding Mover Rear Neutral Lever Stuck - Will Not Push Back In

I have a Craftsman Riding mower model DGS6500. It's automatic and has a lever in the rear you pull out to put it in neutral so you can push it. Well, I was pulling it out and in to hose off the muddy tires and suddenly it didn't push back in. So the lever is stuck and will not push back in! I REALLY need to get his fixed fast.

Does anyone know an obvious fix for this; I'm hoping it's a common thing for Craftsman and is an easy or well documented fix.

Thank you in advance!
-Tony
 
Sponsored Links
  #2  
Old 05-07-17, 04:44 PM
Member
Thread Starter
Join Date: Jan 2004
Location: Harrisburg, PA
Posts: 481
OK, I got it working. I traced the very long rod (that pushed in/out) back to another very short lever it was hooked on to. After trying a lot of things, I pushed upward (towards the sky) on that small lever while pushing on the long rod and it popped back into place. It's not something you can see, you just have to feel around and imagine what's up in there. FYI for anyone that searches for this problem.
-Tony
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes