John Deere Stx 38 won't start after ran over a hose

Reply

  #1  
Old 05-21-17, 06:54 PM
Member
Thread Starter
Join Date: May 2017
Location: Usa
Posts: 1
John Deere Stx 38 won't start after ran over a hose

Okay really it was an electric cord that wrapped around the blades. I have done a hose before and once it was unwrapped it started right up,but after I finished cursing and got the electric cord unwrapped,
I got on and it clicked but wouldn't start. Then, there was no sound at all. Did I mention the electric cord was plugged in! I just recently replaced the solenoid and the starter, so hope I didn't blow those. My husband is a great chef but not a great handyman. He took the battery out and it did say it needed to be charged, so I am hoping it is just the battery..
I guess I am asking if the battery doesn't work what else could it be? Thanks
 
Sponsored Links
  #2  
Old 05-21-17, 08:06 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,820
It could be a number of things but I would suspect a bad battery or battery connection based on your description.
 
  #3  
Old 05-22-17, 04:02 AM
Norm201's Avatar
Member
Join Date: Sep 2013
Location: USA
Posts: 5,974
if you're in need of a manual for that machine, let me know. I've got one on-line I can send you.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes