Briggs stratton pressure washer issue

Reply

  #1  
Old 06-08-17, 06:08 PM
Member
Thread Starter
Join Date: Nov 2012
Location: usa
Posts: 349
Briggs stratton pressure washer issue

I have a craftsman 3300psi with briggs start in engine an am trying to figure out how to reattach governor doing set up.it won't stay in run mode unless I hold throttle correctly an a long long spring has also broken.
Any where I can get pic or info on how to reattach springs an adjust governor?
 
Attached Images   

Last edited by trotter; 06-08-17 at 06:34 PM.
Sponsored Links
  #2  
Old 06-08-17, 10:47 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,575
Looks like you already have it connected properly. The long thin spring just hooks to the carb throttle just like the linkage does, it's not causing a problem like it is. You generally don't want to mess with the governor adjustment unless you've already taken it loose... it should never have to be adjusted. Sounds to me like you have carb problems.
 
  #3  
Old 06-09-17, 12:13 AM
Member
Thread Starter
Join Date: Nov 2012
Location: usa
Posts: 349
There is a very very tiny spring that it wrapped Arians a linkage an the end of spring isn't attached at throttle over carb,the solid wire it's around is but thin spring is around it is not..
 
  #4  
Old 06-09-17, 12:19 AM
Member
Thread Starter
Join Date: Nov 2012
Location: usa
Posts: 349
Pic of small spring that's wrapped around bar to throttle..detatched end also.
 
Attached Images  
  #5  
Old 06-09-17, 10:35 PM
Member
Thread Starter
Join Date: Nov 2012
Location: usa
Posts: 349
I guess I'll resend that spring back into throttle hole an see how it does.
Where are the carberator adjuster screws on these or don't they have them?
I know the governor spring on other side has about10 holes to move spring to also..
Will this help to get even idle?

If throttle is not just right it dies out,
Maybe because of springs not set right.

Any info is appreciated
 
  #6  
Old 06-09-17, 11:12 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,575
It's not the spring. It's not the governor. The carburetor is the problem.
 
  #7  
Old 06-10-17, 04:54 AM
Member
Thread Starter
Join Date: Nov 2012
Location: usa
Posts: 349
So what's it need..a clean out an a adjustment..?

If I hold throttle just right it stays running ok..
 
  #8  
Old 06-10-17, 11:05 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,575
It needs cleaning if it's surging.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 12:32 PM.