Troy Bilt 3000 PSI Pressure Washer with Honda motor -- metallic sound

Reply

  #1  
Old 07-13-17, 11:01 AM
Member
Thread Starter
Join Date: Jan 2014
Location: USA
Posts: 378
Troy Bilt 3000 PSI Pressure Washer with Honda motor -- metallic sound

Hi all

So, I have a 3 year old pressure washer. Been used about a half dozen times. Oil changed every spring. Pressure Washer Pump Saver after (almost) every use

I used the pressure washer last weekend. Worked fine. However, about 2 hours into the job, I noticed a sharp metallic sound when I would release the wand and let the motor get back to idle.

I turned the unit off, checked the oil (it was fine). And it started right back up. Just wondering if I should call Troy Bilt on this, or if thats just a 'normal sound' as the unit ages? Never heard this sound before, so I doubt its the latter.

This is the unit
https://www.lowes.com/pd/Troy-Bilt-3...liant/50328561

Manual here:
http://www.troybilt.com/wcsstore/Tro...9_OpManual.pdf

Any thoughts appreciated as to what to do next. Thanks!
-K
 
Sponsored Links
  #2  
Old 07-13-17, 05:28 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,575
No, it's not a normal sound. The engine mounting bolts may be loose or something worse may be happening.
 
  #3  
Old 07-14-17, 04:26 AM
Member
Join Date: Nov 2012
Location: USA
Posts: 2,973
How hard is it to separate the pump from the motor to see which is making the noise? just a thought.
Geo
 
  #4  
Old 07-14-17, 01:27 PM
Member
Thread Starter
Join Date: Jan 2014
Location: USA
Posts: 378
Hmmm.. I am not as mechanically inclined as I once was. This is a relatively new(ish) unit. I dont want to introduce new issues while trying to solve a minor one... :-/

Maybe I should call the authorized repair place.
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 06:25 PM.