Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

power washer pressure issue valve removal


hereforareason's Avatar
Member

Join Date: Jul 2017
Posts: 3
MI

07-23-17, 09:49 AM   #1  
power washer pressure issue valve removal

I have an old Generac G21 pressure washer.I am attempting to change the uploader valve/kit and am stuck. the model number is 1536-1. This is the one with the nylon nut that was impossible to get out. So now am at the point of trying to get the brass piece that is in the bottom of the cavity out, nothing to grab. any suggestions? This is not a normal valve set up. I am assuming this is the issue as the motor,briggs & stratton runs great but stalls unless trigger pressure is released then no pressure after initial release. then same cycle repeats

 
Sponsored Links
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

07-23-17, 01:27 PM   #2  
Welcome to Doityourself hereforareason!
Sorry, but my experience with these is not good. Good luck getting it apart, I've thrown away those pumps because of what you described. I've destroyed the plastic plug to get it out and then the unloader still would not come out... it's a disposable pump.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
hereforareason's Avatar
Member

Join Date: Jul 2017
Posts: 3
MI

07-23-17, 03:08 PM   #3  
thank you for the reply I had seen a previous post about this type from you. I got the kit,need to for the nut, $18 then the fun started. I was hoping for a cure that I was not seeing. Do you think if I was able to get that out it would be the culprit? Trying to decide if it is worth the time, or worth a new pump , or sell the thing, as the engine is strong, and get a new one. Desire to fix things isn't as strong as it was 20 years ago.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

07-23-17, 08:35 PM   #4  
If you can get it out, that is the likely problem as you suspect. If you manage to get the plug out and see a lot of white chalky looking stuff inside, you probably won't get the unloader out. I hope you can.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
hereforareason's Avatar
Member

Join Date: Jul 2017
Posts: 3
MI

08-13-17, 03:11 PM   #5  
Any help is welcomed!! I have now got the uploader assemble replaced,yea. However but still have the same issue. It will run for about 5-7 seconds and then dies unless I release the pressure by squeezing the trigger. do the 3 brass bolts on the side have anything to do with the pressure release?

 
Search this Thread