17.5 Briggs backfiring and will not run without choke closed

Reply

  #1  
Old 07-29-17, 03:02 PM
Member
Thread Starter
Join Date: Jul 2017
Posts: 3
17.5 Briggs backfiring and will not run without choke closed

I have 17.5 Briggs engine on a LT1000 Craftsman mower. Got it from a friend has not run in 2 years. Changed the fuel line. Added new gas cleaned the carb. Changed the oil and spark plug. Started it yesterday. Ran like a Cadillac for about 10 mins the started surging and died. Cleaned the carb again. Checked the fuel solenoid. Starts and runs again but have to have the choke completely shut off. Runs rough and pops alot. Model # is 31c707. Thanks for any help
 
Sponsored Links
  #2  
Old 07-29-17, 03:21 PM
Member
Thread Starter
Join Date: Jul 2017
Posts: 3
Read some other threads- pull the small wire of the coil. Still surged and died with choke open. Noticed alot of white smoke coming out of intake pipe when the engine dies.
 

Last edited by Jwilson45; 07-29-17 at 03:42 PM. Reason: Spelling
  #3  
Old 07-29-17, 08:49 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,575
Sounds like you still have a carb restriction.
 
  #4  
Old 07-30-17, 08:48 AM
BFHFixit's Avatar
Forum Topic Moderator
Join Date: Jun 2007
Location: USA.
Posts: 1,766
Head gasket .
 
  #5  
Old 07-30-17, 05:31 PM
Member
Thread Starter
Join Date: Jul 2017
Posts: 3
Yep pulled the head off and found a bad gasket. Thank you
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 02:25 PM.