Replacing broken pull cord on power washer.

Reply

  #1  
Old 10-15-17, 12:42 PM
Member
Thread Starter
Join Date: Sep 2007
Location: USA
Posts: 305
Replacing broken pull cord on power washer.

So the pull cord broke on my power washer. I took the housing off thinking I can get to the pull mechanism, BUT it looks like the housing is riveted on. Any advice. Will try and upload pic.
PS: It's a Briggs and Stratton engine. Thanks!
 
Sponsored Links
  #2  
Old 10-15-17, 01:34 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 45,103
There are an awful lot of Briggs and Stratton engines out there.
A model number or picture would be a big help.

How - to - insert - pictures
 
  #3  
Old 10-15-17, 02:45 PM
Member
Thread Starter
Join Date: Sep 2007
Location: USA
Posts: 305
Pete,

Sorry about that. Here are some pics.
 
Attached Images     
  #4  
Old 10-15-17, 03:31 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 45,103
The pull rope replacement in the following link is almost identical to yours.

you tube/watch?v=KciMfHn1Q5Y
 
  #5  
Old 10-15-17, 04:13 PM
Member
Thread Starter
Join Date: Sep 2007
Location: USA
Posts: 305
Pete,

Thanks for the video, will try tomorrow am and report back.
 
  #6  
Old 10-15-17, 07:24 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,817
You remove the entire shroud, not just that round part with the pull rope in it.
 
  #7  
Old 10-16-17, 03:16 PM
Member
Thread Starter
Join Date: Sep 2007
Location: USA
Posts: 305
Thanks everyone. Was able to successfully repair the pull cord. Thanks!
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes