Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

John Deere tractor: ignition module/no spark


zippoman50's Avatar
Member

Join Date: Oct 2017
Posts: 2

10-27-17, 11:26 AM   #1  
John Deere tractor: ignition module/no spark

I have a JD 425 that was running fine the other day and now won't fire. Cranks fine, and I have a green light on my ignition module, but no red light. Changed module to no avail. A friend has the same model and when the key is turned the red light comes on. ,It has a replaced time delay module. Any ideas as to what's wrong would be greatly appreciated.
Thanks,
Zippy

 
Sponsored Links
marbobj's Avatar
Member

Join Date: May 2006
Posts: 3,658
IA

10-27-17, 12:49 PM   #2  
Sit in the seat and bounce up and down a few times. See it that does anything. The seat switch may be acting up.

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,567
GA

10-29-17, 12:50 PM   #3  
Yours has a new time delay module, or your friends does? Time delay module is my first thought... I have a 345 and had the same problem until I replaced it.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!


Last edited by cheese; 10-30-17 at 05:06 PM.
 
zippoman50's Avatar
Member

Join Date: Oct 2017
Posts: 2

10-30-17, 05:47 AM   #4  
ty guys...mine had a replaced time delay module, however it must have went out again because I replaced it and running fine again..however it still doesn't have a red light come on when ignition is switched to on position. But since its running again I won't worry about that..thanks for the information'
Zippy

 
Search this Thread