John Deere tractor: ignition module/no spark

Reply

  #1  
Old 10-27-17, 11:26 AM
Member
Thread Starter
Join Date: Oct 2017
Location: USA
Posts: 2
John Deere tractor: ignition module/no spark

I have a JD 425 that was running fine the other day and now won't fire. Cranks fine, and I have a green light on my ignition module, but no red light. Changed module to no avail. A friend has the same model and when the key is turned the red light comes on. ,It has a replaced time delay module. Any ideas as to what's wrong would be greatly appreciated.
Thanks,
Zippy
 
Sponsored Links
  #2  
Old 10-27-17, 12:49 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,728
Sit in the seat and bounce up and down a few times. See it that does anything. The seat switch may be acting up.
 
  #3  
Old 10-29-17, 12:50 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,815
Yours has a new time delay module, or your friends does? Time delay module is my first thought... I have a 345 and had the same problem until I replaced it.
 

Last edited by cheese; 10-30-17 at 05:06 PM.
  #4  
Old 10-30-17, 05:47 AM
Member
Thread Starter
Join Date: Oct 2017
Location: USA
Posts: 2
ty guys...mine had a replaced time delay module, however it must have went out again because I replaced it and running fine again..however it still doesn't have a red light come on when ignition is switched to on position. But since its running again I won't worry about that..thanks for the information'
Zippy
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes