Vanguard 16 hp v-twin won't keep running

Reply

  #1  
Old 04-14-18, 10:41 AM
Member
Thread Starter
Join Date: Apr 2018
Location: Denmark
Posts: 2
Vanguard 16 hp v-twin won't keep running

When I have the starter running the motor is running but when the key is back in 2 position
It stops running.
I have replaced the key and switch
 
Sponsored Links
  #2  
Old 04-14-18, 10:58 AM
Member
Join Date: Jan 2010
Location: North East Kingdom of Vermont
Posts: 2,412
What condition prompted you to change the Ignition Switch ?

It sounds as though you have a kill wire (wire to the "M" magneto) mis-wired so that it kills the engine when that should only occur when you put it in the Off position.

If the harness hasn't been otherwise altered , then I would be concerned that you have the wrong Ignition Switch.
 
  #3  
Old 04-14-18, 11:38 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,821
It could also be that the carb solenoid is incorrectly wired to the crank signal wire that turns on the starter solenoid.
 
  #4  
Old 04-15-18, 07:36 AM
Member
Thread Starter
Join Date: Apr 2018
Location: Denmark
Posts: 2
the ignition switch is the same as the one that was on it and the problem is the same with both ignitions switches.
when the key is in 2 position der is no power to the fuel solenoid so it is not in the switch.
I have this engien for 12 years running 6 hours every week and then no power on the fuel solenoid only when starter is activ.
 
  #5  
Old 04-15-18, 12:05 PM
Member
Join Date: Nov 2012
Location: USA
Posts: 3,263
Is there a fuse in that circuit, is there power to the solenoid when you are cranking the engine over?
Geo
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes