Snow Chief Auger stops and starts

Reply

  #1  
Old 12-12-18, 04:12 PM
Member
Thread Starter
Join Date: Dec 2018
Location: United States
Posts: 1
Received 0 Votes on 0 Posts
Snow Chief Auger stops and starts

I have a Snow Chief 5 HP/ 20" . Model SC 520ES-N
I inherited it without the owners manual. It has run great for 3 years and now the auger spins all the time with no load but only works part of the time with a load. I was wondering if this model had a shear pin for the auger and where I might look for it to make a replacement?
 
Sponsored Links
  #2  
Old 12-12-18, 04:24 PM
Member
Join Date: Jan 2011
Location: USA
Posts: 4,561
Received 42 Votes on 37 Posts
Tried Google using that model # to find a manual?
Yes most have a shear pin, most just look like a bolt through the auger into the auger shaft.
It needs to be a grade 2 bolt.
 
  #3  
Old 12-12-18, 04:41 PM
PJmax's Avatar
Group Moderator
Join Date: Oct 2012
Location: Northern NJ - USA
Posts: 54,648
Received 517 Votes on 487 Posts
Welcome to the forums.

Shear pins/bolts is one issue. So is a worn out auger gearbox.
 
  #4  
Old 12-12-18, 05:04 PM
Member
Join Date: Jan 2011
Location: USA
Posts: 4,561
Received 42 Votes on 37 Posts
Need to ask is it belt driven?
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: