Cub Cadet 3stage snowblower L wheel no drive

Reply

  #1  
Old 02-18-19, 01:35 PM
Member
Thread Starter
Join Date: Dec 2011
Location: USA
Posts: 72
Received 0 Votes on 0 Posts
Cub Cadet 3stage snowblower L wheel no drive

3 stage Cub Cadet was working fine today, after half an hour the Left wheel lost drive. The Power steering hand lever for L wheel now has too much slack, as if a cable was stretched; it seems intact at the hand lever, must be at the other end near the axle. It gets drive intermittently but no drive uphill. The R wheel operates fine; so I'm pushing it uphill now. any ideas? It was struggling with heavy wet road slush before this problem; maybe too much stress but that's surprising.
thanks!
 
Sponsored Links
  #2  
Old 02-24-19, 11:34 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 17,201
Received 20 Votes on 17 Posts
We don't work on snowblowers down here in the deep South, so I don't have much (any) experience with them... but it sounds to me like the cable broke. Pull on the wire in the cable and see if it comes out of the housing or not.
 
  #3  
Old 02-25-19, 05:25 AM
Norm201's Avatar
Member
Join Date: Sep 2013
Location: United States
Posts: 7,522
Received 80 Votes on 74 Posts
Cheese is correct, it's a cable. Either broken or needs adjustment. I'm betting the adjustment thimble near the bottom got loose and slipped. Should be an easy fix.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: