Troybilt Pony - Starting Problem

Reply

  #1  
Old 11-07-19, 06:00 PM
Member
Thread Starter
Join Date: Nov 2019
Posts: 2
Received 0 Votes on 0 Posts
Troybilt Pony - Starting Problem

2013 TroyBilt Pony. Briggs & Stratton model 31c707-3026 G5, 17.5hp. Bought used April '19. Changed oil, replaced spark plug and fuel filter at that time. Ran fine until last week. Used it for about 20 mins, stopped to empty grass catchers and wouldn't re-start, no matter what.

What I've done:
1. Replaced spark plug, although the one from April looked good.
2. Used an adjustable ignition/spark tester - saw ZERO spark no matter how I set the tester.
3. Ordered new coil. While waiting for new coil to arrive used a wire wheel to clean rust from flywheel and magnet.
4. Replaced Coil/Magneto. Briggs & Stratton website said the original coil was replaced with a model #595304 coil, that's what I installed.
5. Installed and gapped new coil per instructions.
6. Tried starting the mower. The engine ignited for about 3-4 seconds then shut off and NEVER re-fired.
7. Used ignition tester again. Consistent spark seen at the tester's gap size shown in the pic. I do not know which lines on the tester's Small Engine (SE) section represent an approx .30 gap. NOTE: When I adjust the tester any farther out than pictured the spark becomes intermittent then none as I move it farther out.

Fuel (ethanol-free) is fresh, no water.

Does the tester's spark gap shown in the pic confirm that now the coil is working properly?

Please, what's next?

Thanks, Ken
 
Attached Images  
Sponsored Links
  #2  
Old 11-07-19, 07:43 PM
Member
Join Date: May 2006
Location: Iowa!!!!!
Posts: 3,972
Received 3 Votes on 3 Posts
Sounds like the spark is good and with the recent history of it running the flywheel key is likely OK. That leaves what is probably a plugged carb.

Try a spoon of gas down the plug hole and see if it fires. If it does the carb needs cleaning. You can try Sea Foam which works well. Double dose the gas in the tank, choke the engine and spin it over a few times. Let that set for a couple hours and try a restart.

There is a good chance you have a small build up of varnish in the carburetor.
 
  #3  
Old 11-08-19, 11:10 AM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 17,200
Received 20 Votes on 17 Posts
I suspect carburetor as well. Probably water or trash in the bowl.
 
  #4  
Old 11-08-19, 01:40 PM
Member
Thread Starter
Join Date: Nov 2019
Posts: 2
Received 0 Votes on 0 Posts
One step forward, 3 back. Grrrr!

I was checking over stuff before starting the fuel troubleshooting and saw that I had left the wiring harness disconnected after I cleaned it the other day. STUPID! Re-connected it and tried starting. Cranked right up! Cool! Let it run for a few mins and did good. Was elated. Shut it off and put everything back together, engine cover, hood, etc. Restarted and drove it around the backyard w/blades engaged for about 15-20 minutes. Mostly wanted to recharge the battery. Ran fine. Shut down and tried quick restart to see if battery charged, strong crank and started fine.

Went inside for about 30 minutes and came back to it. Tried to start but NOTHING. Flywheel turned maybe half a revolution then a loud THUNK and stopped. Tried a few more times and same.

Then started smelling GAS, REAL strong. Opened hood and the carb was covered in gas. Wiped it down and more appeared. Looked like it was coming from around the (?) throttle shaft, see pic. NOTE: When I was cleaning everything a few days ago, brushing dirt off the carb w/a paint brush, I found a half piece of what appeared to be washer or spacer coming off that same shaft with the spring. Kinda looked like it was made of foam? It was deteriorated so hard to tell. ALSO, gas was seeping out of the hose (at carb) that feeds gas from carb up to top of engine block.

THEN, I glanced down to left and saw gas RUNNING out of the lower front of the mower, out of the MUFFLER. WTH!

With that, and gas still seeping out of the throttle area, I crimped fuel hose from tank and disconnected it.

1. Why/how did so MUCH gas end up in the engine to run out of the muffler?

2. Does the engine 'thunk' mean anything?

Where do I go from here?
 
Attached Images    
  #5  
Old 11-08-19, 05:33 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 17,200
Received 20 Votes on 17 Posts
It's the carburetor. There is an O-ring above the inlet needle inside that usually causes this. You'll need to replace the o-ring.
 
KenH99 voted this post useful.
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes
 
Ask a Question
Question Title:
Description: