B&S 16 HP Vanguard

Reply

  #1  
Old 02-11-20, 12:18 PM
Geochurchi's Avatar
Member
Thread Starter
Join Date: Nov 2012
Location: USA
Posts: 4,175
Received 25 Votes on 24 Posts
B&S 16 HP Vanguard

Hi All, motor runs great, itís relatively new, problem is that when shutting it off it continues to run for maybe 5 seconds after the ignition is turned off, upon further inspection I noticed a terminal and wire hanging loose just under the fuel pump location, there is a wire connected to one side and nothing to the back side, itís has a tab that looks like a wire should be connected to it underneath the housing, could these be the reason for the delay in turning off the ignition switch?

Geo
 
Attached Images  

Last edited by Geochurchi; 02-11-20 at 12:34 PM.
Sponsored Links
  #2  
Old 02-11-20, 01:16 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 17,261
Received 22 Votes on 19 Posts
Possibly. Sounds like the engine is shutting down via the anti-backfire solenoid instead of the actual kill wire.
 
  #3  
Old 02-11-20, 03:33 PM
Geochurchi's Avatar
Member
Thread Starter
Join Date: Nov 2012
Location: USA
Posts: 4,175
Received 25 Votes on 24 Posts
Cheese, any idea if there should be a wire under that cowling ? I guess I should try and remove it and check, where is the anti backfire solenoid is located?
Geo
 
  #4  
Old 02-11-20, 05:56 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 17,261
Received 22 Votes on 19 Posts
There should be a single black wire going to the coils to kill the ignition, then a single or possibly two wires coming out together into a connector for charging (probably going to a regulator on the side) and if it has an anti-backfire solenoid, it will have a wire going to that, possibly two, depending on which type it has. It would be screwed into the carburetor bowl.
 
  #5  
Old 02-12-20, 12:29 PM
Geochurchi's Avatar
Member
Thread Starter
Join Date: Nov 2012
Location: USA
Posts: 4,175
Received 25 Votes on 24 Posts
Problem solved after some disassembly. manufacturing defect.
Geo

 
Attached Images  
  #6  
Old 02-12-20, 06:44 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 17,261
Received 22 Votes on 19 Posts
Glad you got it.
_________________________
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: