Cub Cadet hydro trans barely moves


  #1  
Old 05-23-20, 11:48 PM
S
Member
Thread Starter
Join Date: May 2009
Location: u.s.
Posts: 79
Received 0 Votes on 0 Posts
Cub Cadet hydro trans barely moves

Cub Cadet LTX1050. Circa 2010. Hydrostatic trans 618-0319. Tractor runs fine. Moving forward or reverse it has barely the power to move. On flat ground I'd say it moves at half speed but thats all gone on the slightest incline (like running over a blade of grass). Belt "seems" snug but I don't know how to check accurately. Hate to invest in a forty dollar belt if the hydro is bad. I have been told that this model of hydro is know to wear out but then everything I read says that hydros are notoriously dependable. What say you?
 
  #2  
Old 05-24-20, 03:32 AM
Doorman2722's Avatar
Member
Join Date: Oct 2005
Location: upstate NY
Posts: 951
Received 26 Votes on 26 Posts
Not sure with your model but the older Cubs that I have use a filter for the hydro, I would change it if possible.
 
  #3  
Old 05-24-20, 04:20 AM
B
Member
Join Date: Oct 2015
Location: Ct.,USA
Posts: 2,034
Received 111 Votes on 97 Posts
Have you verified the fluid level in the transmission?
 
  #4  
Old 05-24-20, 10:10 AM
S
Member
Thread Starter
Join Date: May 2009
Location: u.s.
Posts: 79
Received 0 Votes on 0 Posts
There is no filter. Its a sealed unit. Oil level is three quarter inch from top. The manual for the tractor is here https://www.cubcadetpartsnmore.com/u...%202014%29.pdf The hydro-gear manual is on page 237.
 
  #5  
Old 05-24-20, 01:46 PM
S
Member
Thread Starter
Join Date: May 2009
Location: u.s.
Posts: 79
Received 0 Votes on 0 Posts
I forgot to mention this...when the belt is loosened (brake pedal depressed) and I turn the fan by hand it does not spin freely. It takes two fingers to turn the fan. Should the fan spin freely or is the fan under some kind of resistance such as fluid pressure? Or is the fan bound up from defectiveness?
 
  #6  
Old 05-24-20, 08:21 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 17,600
Received 54 Votes on 49 Posts
Sounds to me like you need a new belt.
 
 

Thread Tools
Search this Thread
 
Ask a Question
Question Title:
Description: