Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

generac model2100


's Avatar
Visiting Guest

Posts: n/a

09-06-01, 05:45 AM   #1  
the generator was running fine,then began hunting(revs going up & down)now it wont run properly at all.ive changed spark plug,cleaned filter & the air filter is clean.any ideas?

 
Sponsored Links
Fisher's Avatar
Visiting Guest

Posts: n/a

09-06-01, 09:26 AM   #2  
Fisher
It is caused by a fuel delivery problem . Probably
some trash in the tank and now the carb bowl. Post
the engine's model numbers so we know what you have.
Fish

 
Sharp Advice's Avatar
Admin Emeritus

Join Date: Feb 1998
Posts: 10,440
CAL

09-06-01, 01:58 PM   #3  
Restricted Fuel Supply

Hello and Welcome Chill to the Do It Yourself Web Site and my Small Engine forum.

I agree with Fisher and also suspect a fuel problem. Pull the fuel line off the carb and watch the flow volume and the flow rate. It should be full flowing and remain constant.

Also check the governor linkage. Clean the entire area around the the carbs governor linkage and the linkage with an aersol parts cleaner, if needed. Be sure the linkage moves freely.

Use EXTREME CAUTION cleaning any parts with an automotive aersol parts cleaner product. Aersol liquid parts cleaners may be EXTREMELY FLAMMABLE!!! The manufacturers CAUTIONS should be strictly adhered to.

Regards and Good Luck,
Tom_Bartco
Accurate Power Equipment Company.
Small Engine Service and Repair Technician.

 
Search this Thread