weedeater engine leaks oil

Reply

  #1  
Old 04-22-02, 04:54 PM
meangoat
Visiting Guest
Posts: n/a
weedeater engine leaks oil

I have an XT200 Series FeatherLite Wild Thing WT21 WeedEater and when I look inside the back of the engine cover I see wet oil everywhere. If I lay it down it certain positions it leaks out.
It is a 40:1 fuel mixture and I am near certain it is mixed right.
Help !!!!!!!!!!
 
Sponsored Links
  #2  
Old 04-22-02, 11:29 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,819
The only 2 reasons I can think of that would cause this is either the cylinder bolts are loose, or the brand oil you use is not very clean burning. When the cylinder bolts are loose, small amounts of oil/gas mixture leak out, and the gas quickly evaporates, leaving an oil accumulation behind. Let us know what you find. Those featherlites only run 50 or 60 bucks new, so it might not be worth your trouble.
 
  #3  
Old 04-23-02, 04:51 PM
bwiesner
Visiting Guest
Posts: n/a
Does it run ok? Whose things have a large restricted muffler to cut down on noise and if you don't run them full throttle they don't get hot enough to burn the oil in the fuel mixture. Thus they slobber it out the exhaust. You might try running a bet quality oil, like Husky, Echo, or Stihl. The Poulan Weeder brand has a tendancy to smoke. I believe it is due to the solvent they put in it to make it mix easier. They do that with the cheaper oils. Later Butch
 
  #4  
Old 04-23-02, 08:34 PM
meangoat
Visiting Guest
Posts: n/a
Yes it runs very good Butch. What you are suggesting makes sense though as I rarely run it at full throttle. I will try that as well as upgrading the quality of oil. Thanks a bunch and I will let you know what happens.

Also thanks to Cheese for your suggestions and input.

This is such a great site to get information and save mega bucks in shop repairs. Thanks again guys.

Al
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes