White smoke

Reply

  #1  
Old 06-13-02, 11:23 AM
fl-lawn
Visiting Guest
Posts: n/a
White smoke

I have a b & S 11 hp on my rider mower. I put a new short block in it about 200 hours ago(old one locked up-no oil) and it run fine for 100 hours or so. Then it started blowing white smoke but still run ok, but lately it has been getting worse. Ever time I start it up it smokes like crazy and lacking a little power(it got the right amount of oil in it),soI thought it might be a fuel problem so I replaced the carb with a new one. No difference, still smokes.

So what next ?????????
Head gasket
Valves
Rings

Help Thanks Chris !!
 
Sponsored Links
  #2  
Old 06-13-02, 08:52 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,575
If it's not too full of oil, then it may be the pcv valve. If that is good, I would suspect ring failure. If you have a cast iron sleeved engine, a ring set may solve your problem. If your engine has an aluminum cylinder, it may be scored.
 
  #3  
Old 06-15-02, 11:13 PM
bwiesner
Visiting Guest
Posts: n/a
When you replaced the short block did you check the throttle and choke shafts to make sure they weren't worn out. If they were the engine would suck dirt right past them and ruin your new block. Later Butch
 
Reply


Thread Tools
Search this Thread
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 07:31 PM.