Generator Engine Problem

Reply

  #1  
Old 07-21-02, 09:12 PM
dougie
Visiting Guest
Posts: n/a
Honda generator

Hi I have a Honda generator 5500 watts 13hp motor water cooled motor. electric start
My problem is that when it runs it pump oil from the motor threw a hose that runs from the motor to the air filter houseing almost chokeing out the motor.
Any help would be appreciated
 
Sponsored Links
  #2  
Old 07-22-02, 08:55 AM
telco tech
Visiting Guest
Posts: n/a
That hose is likely to be the crankcase ventilation hose. It allows combustion gases that get into the crankcase to be recirculated into the engine via the air cleaner. If the oil level is to high, oil can get sent back into the air cleaner along with the waste gases and flood the the cleaner element. Check the oil level, also make sure the unit is sitting on level ground, this can cause it to send oil back to the cleaner. Good luck.
 
  #3  
Old 07-22-02, 03:25 PM
dougie
Visiting Guest
Posts: n/a
Thanks
 
  #4  
Old 07-22-02, 09:25 PM
cheese's Avatar
Forum Topic Moderator
Join Date: Jul 2001
Location: USA
Posts: 16,815
Also make sure your air filter isn't clogged. This causes a lot of vacuum in the valve chamber and lets more oil accumulate in there than there should be.
 
  #5  
Old 07-24-02, 04:36 AM
dougie
Visiting Guest
Posts: n/a
Thanks again
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes