Starting and Idle problems

Reply

  #1  
Old 08-27-02, 12:35 PM
dgillisp
Visiting Guest
Posts: n/a
Starting and Idle problems

I have an 1989 Ford Escort Pony, 1.9 liter FI. I've been having problems with no power in 3rd gear and idling problems. It idles rough and acts like it wants to stall out. When the engine starts to warm up and I put it in gear, it does stall and I have to restart it. When I start it, the engine cranks very slowly. I have replaced the spark plugs, distributor and rotor, fuel filter, blow back filter, battery, gound and gounds wires. I put a new alternator in it 3 months back. This has not had any effect. What do you think may be the problem? The cranking problem I think may be the starter and so I'm going to replace it. The idling and power problems, could that be the EGR? I have not an idea.
 
Sponsored Links
  #2  
Old 08-27-02, 05:23 PM
Joe_F
Visiting Guest
Posts: n/a
It could be anything...start with the links and posts in my signature file for starters.

Be careful about spending much more than you have already on this one. These vintage Escorts are collosal heaps and not worth .10
 
  #3  
Old 08-28-02, 01:55 PM
dgillisp
Visiting Guest
Posts: n/a
I replaced the starter and the EGR valve(which was totally plugged up). This has fixed the starter problem and the car didn't stall out this morning as it usually did. I'm still having a problem with the rough idle (not as bad as it was) and no power in 3rd gear. Any ideas?
 
  #4  
Old 08-29-02, 03:17 PM
dgillisp
Visiting Guest
Posts: n/a
I tried getting into the cybrrpartspro website but I don't think it's compatible with my browser. I couldn't get it to come up. I did replace my oxygen sensor and that has improved the idle but I still have the power in 3rd gear problem.
 
  #5  
Old 08-30-02, 06:09 AM
Joe_F
Visiting Guest
Posts: n/a
Use the link AS I have it bookmarked below. Cut and paste if needed. It works.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes