? 87 mazda 323 wagon dies when put in gear and gas applied!

Reply

  #1  
Old 09-05-02, 11:12 PM
binkey75
Visiting Guest
Posts: n/a
Question ? 87 mazda 323 wagon dies when put in gear and gas applied!

Please help! 87 mazda 323 wagon 5 spd. 4cyl. think fuel injected. starts , runs, but when put in gear and given gas it dies. If get it going down the road, it will go a ways until I have to stop for a stop sign than go to take off and it dies again.. Mech. says not a fuel prob. he replaced mass air flow something or other, but didn't help. He's lost on what it could be! Any info greatly appreciated........Kara
 
Sponsored Links
  #2  
Old 09-06-02, 03:53 AM
indigoblue
Visiting Guest
Posts: n/a
Try checking the intake air duct hose for cracks by running your hands around the hose paying attention to the groved areas, especially along the bottom. Common problem with these was cracking or splitting.
 
  #3  
Old 09-06-02, 01:09 PM
binkey75
Visiting Guest
Posts: n/a
Unhappy No cracks in air duct hose!

Mech. checked that first I guess, looks good.fuel pressure has been checked also...Thanks for the reply though. Any other suggestions....
 
  #4  
Old 09-06-02, 04:49 PM
binkey75
Visiting Guest
Posts: n/a
WON'T START NOW! :(

ok now it won't even start, does turn over. has spark, fuel pressure good, is getting fuel. TPS good. air duct good. mass air flow good.
 
  #5  
Old 09-06-02, 05:55 PM
Member
Join Date: Dec 2001
Posts: 2,538
might check ignition rotor sometimes they will short to the distributer shaft, also should chek for injector pulse.
 
  #6  
Old 09-06-02, 09:07 PM
binkey75
Visiting Guest
Posts: n/a
injector pulse ect good.

ignition rotor and all is good ,injector pulse good.. Thank you..
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes