Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

1999 Dodge Dakota ABS


J Ttom's Avatar
Visiting Guest

Posts: n/a

09-06-02, 05:25 PM   #1  
J Ttom
1999 Dodge Dakota ABS

When driving my ABS light comes on then my air bag light. Then the speedometer and tack go to zero. If I press the brake every thing goes back to normal or if I wait a little and not press the brake the engine light will come on and the odometer will flash NO BUSS. This all started a few days after I had my tires replaced. 1999 dodge dakota 5.2 V8 4x4

 
Sponsored Links
Joe_F's Avatar
Visiting Guest

Posts: n/a

09-07-02, 07:06 AM   #2  
Joe_F
Were wider tires put on? If so, they may be hitting the sensor.

Possibility the sensors were damaged by the tire shop too.

 
TECHMAN's Avatar
Visiting Guest

Posts: n/a

09-07-02, 07:21 AM   #3  
TECHMAN
Were taller tires put on if so the V.S.S. sensor in rear of trans is reading diff. than wheel speed and will cause same problem.----Dave---

 
davo's Avatar
Member

Join Date: Apr 2002
Posts: 2,417

09-07-02, 07:47 AM   #4  
abs lamp

I think you need to have your codes checked.Autozone may not be the freebie here.You may have a serial communication problem between modules,causing no buss to display.The antilock module,powertrain control module,instrument panel cluster, body control module and supplemental restraint modules all are tied together through a serial data connection,sometimes referred to as buss.You may need codes read by a Chrysler specific scan tool.Im not sure a generic scan tool would reveal some of the codes.Hopefully its just a broken wire or sensor from having your tires changed,but why would it take several days to occur?Perhaps its a bad ignition switch or loose connection near the brake lamp switch.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

09-07-02, 01:17 PM   #5  
Joe_F
This makes sense.

My uncle called me up on his 1997 LHS that the MIL light was on. I borrowed my friend's Snap On Scanner, but it can't communicate with the computer and I get that "Bus" error message.

I would think the SnapOn thingie could read it!!!

 
J Ttom's Avatar
Visiting Guest

Posts: n/a

09-07-02, 04:20 PM   #6  
J Ttom
I had the same tires put on. auto zone said that the check engine light needs to stay on so they can read it. I will take it to a dodge dealer. Ill let you know what they said.

 
davo's Avatar
Member

Join Date: Apr 2002
Posts: 2,417

09-08-02, 10:27 AM   #7  
Tool companies refuse to accept any liabilaty for improperly repaired vehicle systems.This is why aftermarket scan tools get limited data,Im suprised that they get abs data.The big 3 block them for a good reason.Its all legal crap.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

09-08-02, 10:35 AM   #8  
Joe_F
I believe this is being worked on and sought by the aftermarket as to having the updated information provided by the OEM to the scan tool makers.

 
J Ttom's Avatar
Visiting Guest

Posts: n/a

09-10-02, 01:39 PM   #9  
J Ttom
update well my engine light came on and stayed on I went to autozone they said on oxygen sensor is bad? ok what about the other lights would that cause the other faults?

 
davo's Avatar
Member

Join Date: Apr 2002
Posts: 2,417

09-10-02, 02:00 PM   #10  
No an o2 sensors will not cause your other problems.Autozone can not read the codes I was talking about.Your o2 sensor may not even be bad if you have a bad ground,chaffed wire or serial communication problem you get all kinds of weird things.Have your codes read on a chrysler specific scan tool.If you get codes you can search for a common denominater.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

09-11-02, 07:25 AM   #11  
Joe_F
It's a 1999 truck. You might be able to squeak out free repair from the dealer under warranty.

 
J Ttom's Avatar
Visiting Guest

Posts: n/a

09-20-02, 05:37 AM   #12  
J Ttom
I finaly took i to the dealer they did not find any faults when they read the codes just the o2 sencer they said that the abs sencer will cause all the lights that i was talking about. I think I am just going to wait for it to fail before i replace the abs sencer. thanks for the help
JTtom

 
Search this Thread