brake booster gone south?

Reply

  #1  
Old 09-22-02, 10:56 AM
Member
Thread Starter
Join Date: Jul 2002
Location: corona Ca.
Posts: 471
brake booster gone south?

Hello all, now that I have my tbird running, I can post the rest of it's little probs.

1994 3.8L tbird, recent head gasket and water pump change.

My brakes work great, but then if you just jump on top of the pedal to try to make an emergency stop, it won't. The brake pedal gets stiff stiff stiff. Hard as a rock, and the car comes to a stop a few seconds later.

This problem has been around for at least 2 years, well before any head gasket probs. I don't believe I have any vaccuum leaks.
 
Sponsored Links
  #2  
Old 09-23-02, 05:58 AM
Joe_F
Visiting Guest
Posts: n/a
Sounds like a bad booster. Check your lines to it and check valve thoroughly first!
 
  #3  
Old 09-23-02, 08:46 AM
Member
Thread Starter
Join Date: Jul 2002
Location: corona Ca.
Posts: 471
valve? do you mean the proportioning valve? Never checked that before, how do I check that?
 
  #4  
Old 09-23-02, 08:48 AM
Joe_F
Visiting Guest
Posts: n/a
No. There is a check valve at the end of the vacuum line that snaps into the booster itself. Replace the check valve (a couple of bucks at any dealer to be sure this is not the problem first.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes