1989 Camaro, 305 TBI, Vin E..........Transmission Question

Reply

  #1  
Old 10-01-02, 08:59 PM
Member
Thread Starter
Join Date: Jun 2000
Location: Honolulu
Posts: 91
Question 1989 Camaro, 305 TBI, Vin E..........Transmission Question

Aloha,

In the morning when the car is cold, my transmission lingers in third gear - it takes high RPM to kick into overdrive. What could be causing this, and can you recommend a course of action for this problem? BTW - when the car is warm, the shifting is on time, and not a problem.

Maitai
 
Sponsored Links
  #2  
Old 10-01-02, 09:02 PM
Joe_F
Visiting Guest
Posts: n/a
Change the fluid and filter. Barring that helping, likely internal failure.
 
  #3  
Old 10-01-02, 09:27 PM
Member
Thread Starter
Join Date: Jun 2000
Location: Honolulu
Posts: 91
Change fluid?

Joe,

Do I have to have all the fluid extracted, or just change out what is lost during the removal of the pan?

Maitai
 
  #4  
Old 10-02-02, 03:37 AM
Joe_F
Visiting Guest
Posts: n/a
Drop the pan and change the fluid and filter. You could also alternatively , take the lines off the radiator and use the vehicle to pump out the fluid by starting it. Not really a great idea (running it low and dry) but it "works".

I'd drop the pan and change the fluid and filter if it were me. If that doesn't help, likely internal failure of the tranny. Rebuild time
 
  #5  
Old 10-02-02, 12:16 PM
Member
Thread Starter
Join Date: Jun 2000
Location: Honolulu
Posts: 91
Thanks Joe!!!

 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes