Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

running rough


ronda boyce's Avatar
Visiting Guest

Posts: n/a

10-06-02, 07:35 AM   #1  
ronda boyce
running rough

i have a 88 plymouth voyager with a 2.5 engine that was rebuilt an now it runs rough at times an at other times it runs ok. i replaced the o2 sensor an the temp sensor also auto speed motor. it smells like fuel is being wasted. also a knocking underneath by the exhaust. any advice as to what to do next? i am doing the repairs an have come up with no solution

 
Sponsored Links
Joe_F's Avatar
Visiting Guest

Posts: n/a

10-06-02, 07:39 AM   #2  
Joe_F
Start with the links and posts in my signature file below.

Does the knocking get louder/more intense with the engine RPM? If so, possibly a poorly rebuilt engine with internal failure again

 
ronda boyce's Avatar
Visiting Guest

Posts: n/a

10-06-02, 07:44 AM   #3  
ronda boyce
the knocking only does it when i start the van until it warms up.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

10-06-02, 07:46 AM   #4  
Joe_F
Mileage? Last time it saw a tuneup? Fuel pressure? Trouble codes stored in the computer? Any exhaust leaks?

etc, etc, etc, etc, etc, etc....

Lots to check out and verify---can all contribute to your problem. Again, start with the links and posts I have below.

 
ronda boyce's Avatar
Visiting Guest

Posts: n/a

10-06-02, 07:51 AM   #5  
ronda boyce
the trouble codes are12-15-22 also yes there is an exhaust leak toojust pit new plugs in

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

10-06-02, 10:17 AM   #6  
Joe_F
Must rectify the exhaust leak.

Go to www.batauto.com and look up your trouble codes and what they mean. Look at those systems/circuits for problems first before going any further.

 
Search this Thread