check engine light 1982 cutlass

Reply

  #1  
Old 10-16-02, 04:17 PM
broman1960
Visiting Guest
Posts: n/a
Cool check engine light 1982 cutlass

I have a 1982 cutlass supreme v6 231 2 bbl, the check engine light comes on after as soon as the car starts, then it flickers and stays on after about 5 mins, the car ran fine until recently, I tried having a mechanic pull the codes and no codes showed I have recently changed the computer, chip, plugs, wires, egr valve, rotor and cap, and belts. It runs fine for about and hour of driving and then it starts the hesitate, it doesn't stall but when I press the gas pedal it sort of surges and the power is not up to normal. Help!!!!
 
Sponsored Links
  #2  
Old 10-16-02, 05:28 PM
Joe_F
Visiting Guest
Posts: n/a
Have the grounds to the computer and in the engine been checked for tightness and soundness?

Have the car put on an engine analyzer at a shop. They can then simulate the condition and see what's happening in the engine and what's causing it.

Be careful about dumping too much dough into a 231 V6. They are collosal junk and don't last long as they have poor oiling systems .
 
  #3  
Old 10-17-02, 07:30 AM
broman1960
Visiting Guest
Posts: n/a
Thanks for the info, I always stay on top of the engine, I bought the car brand new and haven't had any major problems with the car, I did notice that around the oil plug and the oil filter it is coated with dirty oil, I will clean that section of the engine and update you.
 
  #4  
Old 10-17-02, 06:44 PM
Member
Join Date: Apr 2002
Location: Pittsburgh,Pa
Posts: 2,417
Have someone else check your codes.See if you have #23 or #53.Do you have access to a dwell meter or scan tool?You can do it yourself by jumping a and b together in the diagnostic connector.It will flash the codes to you if you don't know how let me know.
 
  #5  
Old 10-19-02, 04:51 PM
broman1960
Visiting Guest
Posts: n/a
I had someone try to pull the codes and it kept coming up that the computer wasn't communicating, we also tried the a b jump and still nothing the light didn't flash at all. he thinks that the computer or the chip is bad, which I changed on the car about a year when I started getting the check engine light, any other suggestions? please help
 
  #6  
Old 10-19-02, 10:25 PM
Joe_F
Visiting Guest
Posts: n/a
Check that all the grounds are intact and sound.

Barring that, have the computer sent out for testing to be sure it's not defective. Any auto parts store can handle that for you.
 
  #7  
Old 10-20-02, 07:13 AM
Member
Join Date: Apr 2002
Location: Pittsburgh,Pa
Posts: 2,417
On older GM cars you have a remote lamp driver that could cause the check engine lamp to not flash.I'm trying to find the 1982 chart but I have come up empty so far, but I will keep looking.If you have a book for codes I suggest you try finding the chart check engine light on all the time or won't flash code 12.This might put you in the right direction.
 
  #8  
Old 10-23-02, 05:57 PM
broman1960
Visiting Guest
Posts: n/a
Thumbs up

can you tell me where I can find the codes, I have the haynes manual and the chilon manual both indicate the codes that register. Thanks, your forum really rocks
 
  #9  
Old 10-23-02, 11:37 PM
Member
Join Date: Sep 2002
Location: Colorado
Posts: 431
See if this link helps you with code access.
http://www.batauto.com/GM
Almost forgot...does that have the HEI(High Energy Ignition) system. If it does than the Ignition module in the distributor are known to become heat sensitive and cause havoc. Also the coils can create problems.
 
  #10  
Old 11-09-02, 10:10 AM
broman1960
Visiting Guest
Posts: n/a
would the oil pump also play havoc ?
 
  #11  
Old 11-09-02, 09:05 PM
Joe_F
Visiting Guest
Posts: n/a
Not likely. The oil pump would be a mechanical issue, not an electric one.
 
  #12  
Old 11-10-02, 12:41 PM
broman1960
Visiting Guest
Posts: n/a
thanks alot. in my opinion this group is the best on the planet.
 
  #13  
Old 11-15-02, 04:32 PM
broman1960
Visiting Guest
Posts: n/a
I think I might have found the hesitation problem, I had a dummy alarm light installed by a friend on the car(sort of like night rider light in the front). the light is mounted on the dash, I did notice lately that the light flickers on when I'm driving and it's not supposed to, so I will disconnect it and I'm quite sure it will stop, I also added an after market tach to the car, would it have something to do with it?
 
  #14  
Old 11-16-02, 06:16 AM
Joe_F
Visiting Guest
Posts: n/a
Why on God's green earth would you do that? Lol.

You can't nearly spool up a 231 V6 to need a tach and most aftermarket installs are hokey and troublesome. Remove all these"accessories" as you may have created a short by doing so.

The 231 V6 is complete crap in these vehicles and it takes all hands on deck to make them run even half way decent. I had one (1979, non computer command) and it lasted because I was anal with the maintenance on it. I wouldn't have sold it if it were a 260 Olds V8 or a Chevy V8.

Also, check your alternator output carefully. Use my post "The Basics" to guide you.
 
  #15  
Old 01-17-03, 07:30 AM
broman1960
Visiting Guest
Posts: n/a
Thumbs up

the problem has been solved I had a bad computer
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes