Jammed

Reply

  #1  
Old 10-23-02, 05:25 PM
Stones
Visiting Guest
Posts: n/a
Jammed

1967 mustang, 351 windsor, 3 speed manual tranny.

Problem...shifter/tranny stuck in first gear, clutch still engages and disengages. I just bought the car, and yesterday i noticed it was tough getting the tranny into reverse...got the grrrrr - grrrrrr - clunk...... supposably it has a new clutch.

any suggestions?
 
Sponsored Links
  #2  
Old 10-23-02, 05:32 PM
Joe_F
Visiting Guest
Posts: n/a
To my recollection the 351W was not used in this year Mustang. Sounds like it was cobbled together.

How are you sure the clutch is engaging and disengaging?

Additionally is there any fluid in the gearbox?

Can you manually disconnect the linkage and move things around?
 
  #3  
Old 10-23-02, 06:06 PM
Stones
Visiting Guest
Posts: n/a
I belive it originally came with a 6cyl.

When I press the clutch in, the car stops, and when I relese it , it moves.

I assume there is fluid in the gearbox
Havent disconnected linkage, will try that tomorrow

Hopefully that is the prob..bent linkage..

When it happened, i was accelerating fast, and shifing just as fast, and seems like it is jammed between 1st and 2nd (shifter location anyway).
 
  #4  
Old 10-24-02, 06:05 PM
Stones
Visiting Guest
Posts: n/a
cotter pin fell out of linkage, and linkage wedged itself.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes