Sunfire- Brakes grabbing on hard stops

Reply

  #1  
Old 10-25-02, 05:42 PM
CrAzy LEgz
Visiting Guest
Posts: n/a
Sunfire- Brakes grabbing on hard stops

Hello all! I have a 96 Sunfire GT, 2.4L, 5 speed manual; Leaving work today I noticed for the first time that the brakes (seemed like front) started grabbing as I was making harder stops. In other words, the brakes seemed to lock then release several times a second instead of just applying even pressure. The prob seemed to go away as I drove it (caustiously) a little further.
I haven't jacked it up yet to have a look at the brakes, but I was wondering if anyone else might have a suggestion. I'm suspecting power booster or check valve.

Btw, it was raining heavily today but not when I had the prob.

Thanks in advance.
 
Sponsored Links
  #2  
Old 10-25-02, 06:18 PM
Joe_F
Visiting Guest
Posts: n/a
Does the vehicle have ABS?
 
  #3  
Old 10-26-02, 09:51 AM
CrAzy LEgz
Visiting Guest
Posts: n/a
Thanks for the reply

Yes it does.
 
  #4  
Old 10-26-02, 11:12 AM
CrAzy LEgz
Visiting Guest
Posts: n/a
One more thing...

Also, this was very noticable difference in the braking of the car, not just the ABS I get under normal hard braking.
 
  #5  
Old 10-26-02, 03:08 PM
Joe_F
Visiting Guest
Posts: n/a
Could be an ABS problem or a hydraulic one. ABS systems require specialized tools, service procedures and knowledge to service correctly.

It could also be clogged rubber flex lines which act as check valves and make it stick.

Suggest professional service on this one.
 
  #6  
Old 10-26-02, 04:04 PM
CrAzy LEgz
Visiting Guest
Posts: n/a
I'm afraid your'e probably right, thanks for the response. I'll post back when I find out what it is.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes