Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

No Heat


Dandy Don's Avatar
Visiting Guest

Posts: n/a

10-30-02, 06:33 PM   #1  
Dandy Don
No Heat

I have an S10 with a 4 cyclinder engine. I just drove 24 miles. I was going 65 miles an hour. The outside temp is 42 degrees. The heater was not working very well. When I got home I was going to check the water in the radiator. It was pretty low and had about a half an inch of foam on top of the water. The water was cool to the touch. The color of the water was the same as coffee with milk added to it (a tan color). I have a mix of antifreeze/water that is good to 10 degrees. Why the foam? Why was the water in the radiator cool to the touch? Why was it a light tan in color? Thanks

 
Sponsored Links
bejay's Avatar
Member

Join Date: Dec 2001
Posts: 2,538

10-30-02, 06:58 PM   #2  
have you ever had your cooling system flushed?
check your oil is it normal in color?
need to have cooling system pressure tested and checked for leaks and flushed may also be a good idea to replace thermostat, and all hoses if hasnt been done within the last 2 years.
usually it can turn the color you are describing just from failing to service the cooling system by flushing and replacing coolant and hoses every 2-3 years, sounds like you may have a leak somewhere now though also.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

10-31-02, 09:20 AM   #3  
Joe_F
Also check the oil dipstick, is it like a milkshake in color or consistency?

If so, blown head gasket.

 
Search this Thread