98 Venture electric problems

Reply

  #1  
Old 11-01-02, 06:58 AM
Member
Thread Starter
Join Date: Apr 2001
Location: USA
Posts: 257
98 Venture electric problems

Back on the 13th of October the van died in my driveway. No juice to start it or even electrically lock the doors. Told the wife that I had planned to get a new battery before winter anyway because it was the original and was about do for replacement. Monday morning I jumped it with my other car and off to the service center I went. They put it on the meter and yep "bad battery" but they also said that the alternator was trying to charge at 2 times its normal rate. They put the new battery in and tested everything again and the alt. reading was normal they concluded that it was high previously because of how dead the battery was. Last Saturday 10/26th same thing happened again. Dead in the driveway, this time with a new battery. Took it to a different service station after jumping it. They said "bad battery", I told them it was new and they said sometimes you get a bad one because it was not holding a charge. They put a new one in and I returned the other one as defective. Now the low coolant light and airbag light stay lite on the dashboard. The coolant is where it belongs and I do not know how to check the air bag. I think something electrical is going on. How can I check this out before the wife becomes stranded and I never hear the bottom of it?

Thanks,

Doug
 
Sponsored Links
  #2  
Old 11-01-02, 04:30 PM
Joe_F
Visiting Guest
Posts: n/a
I have how to do an output test for the alternator in my post "The Basics". Do that and tell us what you find.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes