no heat 1996 Blazer

Reply

  #1  
Old 11-06-02, 11:32 AM
jbryant
Visiting Guest
Posts: n/a
Question no heat 1996 Blazer

My 1996 Blazer (4.3) is blowing cool air instead of heat! The engine temp is normal and there is only a minimal temp difference in the air when I switch the dash control from cool to warm. It also seems to blow harder on cool setting than warm setting. I have already flushed and filled the radiator. Could the thermostat be bad or would the engine be overheating? Also, is there any electronic sensor somewhere that could cause this? Hopefully it is not the heater core. I have noticed no obvious leaks anywhere. Could it be the heater door and if so, is that something easy to do?
 
Sponsored Links
  #2  
Old 11-06-02, 02:05 PM
davidf
Visiting Guest
Posts: n/a
What is it with all these heater problems.Are the manufacturers using some sort of cheap metal for the heater fins now?Maybe the heater rad fins are aluminum now and push out easilly after four years.If temp guage reads normal then you should get heat unless you have an engine problem or you put in a summer thermostat.Is your engine running normally,no smoke or burning oil or knocks noise?
 
  #3  
Old 11-06-02, 04:40 PM
Joe_F
Visiting Guest
Posts: n/a
Feel the heater hoses going to the heater core with the vehicle fully warmed up.

If they are hot, the problem is with the vent door inside the truck.

If they are not, cooling system issue.

Start there.
 
  #4  
Old 11-06-02, 05:18 PM
jbryant
Visiting Guest
Posts: n/a
No engine problems or noises! I do not know if the thermostat has been changed or not since I haven't had the vehicle that long. The hoses to the firewall are warm but not hot!
 
  #5  
Old 11-06-02, 05:39 PM
davidf
Visiting Guest
Posts: n/a
At normal engine temperature the heater hoses should be hot.Maybe your fan is coming on prematurely.At this time of year the fan should not come on at all except at a lengthly time of engine idle.What deflection is your temperature guage. It should be 2/3 full deflection.Is it low like 1/4 which means overcooling and probably is a prematurely opening thermostat.I drove around with no thermostat one summer and it took hours of driving before the temp. guage reads normal temperature and for most regular hops around town of 20 minutes to half an hour the temp guage barely moved.
 
  #6  
Old 11-06-02, 05:43 PM
jbryant
Visiting Guest
Posts: n/a
My thermostat never runs over around 160-170 degrees in summer or winter. Would a new thermostat solve this?
 
  #7  
Old 11-06-02, 06:02 PM
TECHMAN
Visiting Guest
Posts: n/a
96 Blazer----- Do you have a control lever are i think this year mod have a push botton on dash. If you have push botton on dash than you may have a blend air door motor bad under dash. Make sure your heater hoses are hot and go under dash in the center about where the asy tray is and you will find the blend air door and you may tap on the motor to get it to move. Let me know if i am on track here are not.---Good Luck -----Dave-----
 
  #8  
Old 11-06-02, 06:31 PM
jbryant
Visiting Guest
Posts: n/a
this has a dial not a pushbutton. The hoses do not get very hot. Even the radiator cap is not real hot.
 
  #9  
Old 11-07-02, 06:27 AM
Joe_F
Visiting Guest
Posts: n/a
Start by flushing the system and replacing the thermostat.

Tell us what that nets you.
 
  #10  
Old 11-07-02, 07:11 PM
TECHMAN
Visiting Guest
Posts: n/a
Yes this has a dial for the hot and cold and a push buttom for a/c and rec. wright. If so you do have a blend door that has a motor on it. Take care of the thermostat prob. first but dont forget the blend motor.---GOOD luck-Dave---
 
  #11  
Old 11-07-02, 08:12 PM
Member
Join Date: Apr 2002
Location: Pittsburgh,Pa
Posts: 2,417
If you have dexcool which I'm sure you do.Flush the heater core,it's plugged.It's been a problem on these vehicles.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes