Power steering question

Reply

  #1  
Old 11-08-02, 05:27 AM
Antony W. Serio
Visiting Guest
Posts: n/a
Power steering question

I have an 88 S-10 4x4 pickup with a 4.3 engine, a 700R4 and 235000 miles. I recently had the ball joints replaced, which has drasticly improved the handling of this old girl. After I got the truck back from the mechanic, I have experienced very stiff steering when I first start the truck in cold weather. For the first few turns of the steering wheel, it is almost like there is no power steering. However, the steering quickly improves. I have also noticed that I can hear the pump squeal during sharp turns when the truck is cold now. When the weather is warm, I have not had any problems. The weather has been un-naturally warm until immediately after I had the ball joints replaced, so I do not know if the problem existed before I had the work done. I did not notice the problem last winter. I have not noticed any P/S fluid leaks, and my mechanic said that he lubed everything. I have been told that I may need to have the P/S fluid flushed. Could this be the problem, and is this something that I can do myself?
 
Sponsored Links
  #2  
Old 11-08-02, 08:29 AM
tstokka
Visiting Guest
Posts: n/a
how is the level of the power steering fluid?
 
  #3  
Old 11-08-02, 09:13 AM
Antony W. Serio
Visiting Guest
Posts: n/a
The P/S fluid is full and looks clean.
 
  #4  
Old 11-08-02, 01:52 PM
davidf
Visiting Guest
Posts: n/a
Fill only to the full index mark and not past it .
 
  #5  
Old 11-08-02, 01:55 PM
davidf
Visiting Guest
Posts: n/a
Loose P.S. belt will cause that problem.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes