no heat 97 chevy 1500 sub

Reply

  #1  
Old 11-08-02, 09:39 PM
sircharles
Visiting Guest
Posts: n/a
Question no heat 97 chevy 1500 sub

temp hand goes to 110 to 220 no heat and the front or back ran hot one time and now i have no heat.
 
Sponsored Links
  #2  
Old 11-09-02, 02:25 AM
BobQ
Visiting Guest
Posts: n/a
Is the fluid level where it belongs? If it isn't then you need to find out why. It could be a stuck thermostat or a leak from a variety of places;hoses,gaskets,radiator,water pump,etc. If the water pump is leaking,it needs replacing. If you notice the engine performing poorly and/or white smoke from the tailpipe,you could have a head gasket problem.
You need to check these things out,then someone can help you out in repairing the problem.
 
  #3  
Old 11-09-02, 06:56 AM
Joe_F
Visiting Guest
Posts: n/a
I agree. Need more information.
 
  #4  
Old 11-09-02, 01:13 PM
sircharles
Visiting Guest
Posts: n/a
Engine runs poorly,white smoke out of tailpipe,no visible coolant leaks on the ground,heater core was replace, runs hot, there's bubbling noise coming from the right side, sounds like something is about to fall from the bottom,also check engine light is on. About how much will this be to get fixed.
 
  #5  
Old 11-09-02, 08:54 PM
Joe_F
Visiting Guest
Posts: n/a
Unhappy

Blown head gasket/cracked head(s). Time for an upper half overhaul.

Prices vary by the shop and whether or not the heads are cracked.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes