1995 Mercury Villager Headlight no lowbeam - only high working on one of the headligh

Reply

  #1  
Old 11-11-02, 07:49 PM
jeffsherry
Visiting Guest
Posts: n/a
Question 1995 Mercury Villager Headlight no lowbeam - only high working on one of the headligh

Hi. We have a 1995 Mercury Villager. We noticed that the passenger side headlight wasn't working so we bought a new bulb. However, it still wouldn't light up. Subsequently, we found that the same bulb would light up if we put on the high beams but not the normal headlight beams. We switched the bulb and know it's not defective (it worked in the other headlamp for both low and high beams). What else could be wrong? Can we fix this ourselves since we are unemployed for past 8 mos. and trying to save money. Thanks much.
 
Sponsored Links
  #2  
Old 11-12-02, 05:06 AM
Joe_F
Visiting Guest
Posts: n/a
If all the bulbs check out, you may have a bad dimmer/multifunction switch in the steering column.

See autolibrary.org below in my signature file to see if they have the R&R procedure and testing procedure.

If it tells you to disarm the airbag, stop here. Seek professional service. You can compromise the integrity of the air bag system if you don't have the proper tools to service it.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes