Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

gas smell


mmina's Avatar
Visiting Guest

Posts: n/a

12-13-02, 07:59 AM   #1  
mmina
gas smell

hi

I have a 1998 hyundai elantra which has approximately 80000 miles on it. yesterday, I took it for a major tune up where the fuel filter was changed besides other things that are changed. Since then, every time I start the car, there is a smell of gas, not very very strong but still strong enough to smell. Then I can smell the gas a little bit once a while when driving. Any suggestions would be greatly appreciated as to what may be causing this problem. does a new fuel filter have such a smell and it disappears slowly?

 
Sponsored Links
fordman30's Avatar
Visiting Guest

Posts: n/a

12-13-02, 10:53 AM   #2  
fordman30
gas smell

carry back and have them to check for a leak

 
davidf's Avatar
Visiting Guest

Posts: n/a

12-13-02, 02:19 PM   #3  
davidf
They probably spilled gas when they changed the gas filter.It happened to me several months ago as I was watching they spewed gas all over the battery while removing the gas filter.

 
mmina's Avatar
Visiting Guest

Posts: n/a

12-16-02, 08:14 AM   #4  
mmina
Thank you

Thanks to both of you for replying. I took the car back to the mechanic and I mentioned that occassionally, I smell gas inside the car but not from outside. His response was "But I don't smell any gas.Then again my clothes are damped in fuel since I am a mechanic." He looked at the fuel filter and said that it did not have any leaks. I suggested to him that I would come back next week if I can still smell gas and he should look at it then. Hopefully, he would look at it. I just wanted to know what could be causing that so I can make suggestions to him, if he has no clues.

thanks

mina

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

12-16-02, 10:35 AM   #5  
Joe_F
Have him relook at any connections that may have been disturbed in the work he did. Barring that, did you make sure the gas cap isn't loose or the seal is broken on it?

 
Search this Thread