chevy suburbon 92 lost power

Reply

  #1  
Old 12-26-02, 08:47 PM
slotchie69
Visiting Guest
Posts: n/a
Unhappy chevy suburbon 92 lost power

i have a 1992 chevy suburbon atomatic air conditioning 4 wheel drive v-8 bought from second hand dealer me and my wife were traveling to boisie on the highway doing about 80 when the vehical lost power not the motor but the driving force but it would kick back in at lower speeds well needles to tsay that the 1st and 2nd worked sorta but when you got to higher speeds it would like cut out again die down losse force powere again the motor was running fine well we got as far as the next exiot but i think from pushing the motor to hard to get us there i might have blown a rod or something there is a like a mechanical knocking sound on the left side lookinf from bumber to winshield so i dont know what the problem is or how to fizx it if any one can help it would be areciated cause i dont want to spend 5 grand to get a new tranny and motor installed quick respond requested
 
Sponsored Links
  #2  
Old 12-26-02, 09:12 PM
Joe_F
Visiting Guest
Posts: n/a
If you hear a metallic rapping coming from the lower end, it could be a rod failure, yes.

You did check the oil level to be sure it's full and clean, right? .

Next thing to do is to get an oil pressure gauge rented from a parts store (like Autozone) and do an oil pressure check. Check the readings with the rented gauge versus those in Autolibrary.org (accessed through the "Basics" link below).

Tell us what an oil pressure check reveals.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes