Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

94 Camry Idiot light question


trinitro's Avatar
Member

Join Date: Jan 2002
Posts: 1,915

12-30-02, 01:28 PM   #1  
94 Camry Idiot light question

I have a 94 Camry (2.2, Auto). The last couple of days a "new" to me idiot light came on. It's orange in color, and it's on the bottom left side of the cluster. It looks like the picture of a car with the rear lights "on". My first guess was that one of the brake bulbs is not working. However, all seem to work ok. The light will be off when I start the car, and will come on either right when I press the brake pedal, or shortly after. It will sometimes flicker on or off, similar to a loose connection. But not always. I looked at Alldata, but I could not find a picture of the cluster. First I would like to know if that light is indeed a brake bulb idior light, and if so, what is the most likely source? Next I guess I'll go and check each bulb for a good connection....

 
Sponsored Links
Joe_F's Avatar
Visiting Guest

Posts: n/a

12-30-02, 01:30 PM   #2  
Joe_F
Burned out, improperly installed or wrong part # bulb installed, or a break in the wiring in the rear quarter area. Common on this era Camry as Larry "Toyotaman" will attest to.


Last edited by Joe_F; 12-31-02 at 11:18 AM.
 
trinitro's Avatar
Member

Join Date: Jan 2002
Posts: 1,915

12-30-02, 02:05 PM   #3  
I've had this car for a bit over a year, and nothing was changed (bulb wise). I'll wait and see if Larry has another possible solution.....

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

12-30-02, 02:16 PM   #4  
Joe_F
Check all the bulbs carefully in the meantime. If any are blackened or on the verge of burning out, replace them with the proper part #. Check the lamps closely, bet you'll find one of the burned out or blackened.

(Same thing just happened on my uncle's 97 Taurus this past Saturday. I changed both high mount stop lamp bulbs and the light went right out).

 
trinitro's Avatar
Member

Join Date: Jan 2002
Posts: 1,915

12-30-02, 02:21 PM   #5  
Will do that tomorow morning... after I get the heater for the garage.

 
the_tow_guy's Avatar
Group Moderator

Join Date: Feb 2001
Posts: 11,477
FL

12-30-02, 04:23 PM   #6  
Definitely check the 3rd brake light. Mine went and I was going nuts trying to figure out why the warning light was on until I noticed the hi-mount burned out.

 
michael van's Avatar
Member

Join Date: Nov 2001
Posts: 2,345
TX

12-30-02, 07:29 PM   #7  
check this

If my old memory serves me right that warning is for any light that is inop.Dont just check the brake lights but all running lights as well.

 
toyotaman11769's Avatar
Member

Join Date: Jun 2002
Posts: 1,531

12-31-02, 06:37 AM   #8  
Everyone has sent you in the right direction.

Just a hint....pay attention as when the warning lite lights up

Only turning on Tail lamps not hitting the brake= tail lamp problem

Applying the Brake=brake light problem

Larry

 
trinitro's Avatar
Member

Join Date: Jan 2002
Posts: 1,915

01-01-03, 01:23 AM   #9  
I've found it...it was a dual-purpose bulb, both for the brake and the lights. The brake filament works fine, but the ligh filament only works when it wants to. A new bulb fixed the problem...thanks.

 
michael van's Avatar
Member

Join Date: Nov 2001
Posts: 2,345
TX

01-01-03, 05:58 AM   #10  
good deal

Great you found the bulb and fixed it.That idiot light is a pretty good feature My 97 Camry had it.(to bad my ex got the car)My new Toyota does not have it but I check all bulbs on a regular basis anyway.

 
Search this Thread