90 chevy 1500 4x4 light problem

Reply

  #1  
Old 12-30-02, 03:52 PM
jarhead1234
Visiting Guest
Posts: n/a
Thumbs down 90 chevy 1500 4x4 light problem

Help,
All of the sudden my 1990 chevy 1500 4x4 p/u has no stop/tail/turn/back up lights. Symptoms; left front turn signal blinks very quickly indicating a problem. front right turn signal works fine. All rear lights do not work or respond to a test light. dashboard turn signal indicators mirror front turn signals. Flasher module is new (6months) and is clicking when signals blink. no obvious blown fuses. I am told that water in a light can cause similar symptoms, true or false, the front turn signal that blinks fast is warped and will alllow water in if exposed. Any ideas would be greatly appreciated.
thank you
Jarhead
 
Sponsored Links
  #2  
Old 12-30-02, 04:39 PM
Joe_F
Visiting Guest
Posts: n/a
Check that all the rear bulbs are the proper part #, installed correctly, and not burned out.

Barring that, it sounds like a bad ground/broken wire.
 
  #3  
Old 12-30-02, 07:16 PM
Join Date: Dec 2002
Location: Connetisuck
Posts: 162
Those tail lights used a circuit board that the lamps plug into. They are notorious for failing. You can take them apart and clean them and replace any burned bulbs, but if they are smoked it is a dealer item. I've replaced several.
 
  #4  
Old 01-01-03, 03:29 PM
jarhead1234
Visiting Guest
Posts: n/a
Wink fixed it

Thank you for your help. Upon closer inspection I realized I missed the obvious, the trailer hitch wire harness was apparently ripped off and with it went my ground wire. Rewired the plug and attached a new ground, good as new. (for now).

Thank you again
Jarhead
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes