Welcome to the DoItYourself Forums!

To post questions, help other DIYers and reduce advertising (like the one on your left), join our DIY community. It's free!

tranny troubles


crosswind's Avatar
Visiting Guest

Posts: n/a

01-16-03, 03:25 PM   #1  
crosswind
tranny troubles

1994 Ford Explorer, 6 cylinder, automatic.one day no problems, next day tranny wont shift. goes from first to second fine, but not into third. RPM's get way high, almost red line, then i back off, and when the RPM's get down around 2000, the tranny shifts smoothly into third. Same story for third to forth, get my speed up, then coast until RPM's get down to about 200, and then the tranny shifts smoothly idnto fourth. Fluid level is perfect, color is clean, no leaks anywhere, no strange sounds at all.??????

 
Sponsored Links
YamahaWolverine's Avatar
Member

Join Date: Dec 2002
Posts: 162

01-16-03, 03:43 PM   #2  
Check the governer.

 
Joe_F's Avatar
Visiting Guest

Posts: n/a

01-16-03, 04:28 PM   #3  
Joe_F
Sounds internally wiped. Mileage?

When did it see a tranny service last?

 
cheese's Avatar
Forum Topic Moderator

Join Date: Jul 2001
Posts: 16,574
GA

01-17-03, 12:12 AM   #4  
AOD tranny? If so, before throwing in the towel, check the governor. They are SOOO picky about the least speck of debris.

Like Joe mentioned, servicing it might help if it's been awhile. Has the radiator been removed lately? Sometimes garbage gets in the tranny via the cooler lines to the radiator.


"Who is John Galt?" - Ayn Rand (Atlas Shrugged)

God bless!

 
Search this Thread