Radio LED not lit on my Bonneville

Reply

  #1  
Old 01-31-03, 08:59 AM
norbeast1
Visiting Guest
Posts: n/a
Radio LED not lit on my Bonneville

I have a 1997 Bonneville SE (40th anniversary edition) that is having a lighting problem. The LED light showing the radio station and the time display has quit working. It started going haywire in the last two weeks. At first it would work intermittently, sometimes on, sometimes off. Now it is not on at all. The other dashboard lights are not affected at all, just the one I mentioned so I don't think a fuse is involved. The radio has two independent sets of controls, one on dash and one on the steering wheel.

Does this sound like a dealer only fix it and does it sound expensive to troubleshoot? I can live with it the way it is but would prefer not to. Thanks.
 
Sponsored Links
  #2  
Old 01-31-03, 09:22 AM
Joe_F
Visiting Guest
Posts: n/a
Burned out bulb inside the radio, wasted LED or other wiring problems.

Best bet is to take out the radio and have it repaired and do the R&R yourself.
 
  #3  
Old 01-31-03, 09:52 AM
norbeast1
Visiting Guest
Posts: n/a
Thanks!

Your advice and links are very helpful. I think I will take it in to a pro for this one.

 
  #4  
Old 01-31-03, 01:30 PM
Joe_F
Visiting Guest
Posts: n/a
You can take them just the radio and have them look at it, saving the labor of them removing it for you.

Autolibrary.org below should have the R&R instructions for the radio.
 
  #5  
Old 01-31-03, 06:42 PM
Member
Join Date: Sep 2002
Location: Colorado
Posts: 431
You could also call the dealer/parts counter guy and find out who does their warranty work on radios. There might be a local shop that will work on it as all the dealer will probably do is remove the radio and send it away to the same repair shop. Many times a radio repair shop can remove, repair and reinstall while you drink their bad coffee in the lounge. Just a thought.
 
Reply

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Thread Tools
Search this Thread
Display Modes